Montag, 11. November 2019, 23:59 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 657

Wohnort: Neuenhagen b. Berlin

21

Mittwoch, 10. April 2019, 22:05

... und noch etwas, was eventuell zur Eingrenzung des Fehlers hilfreich ist:

Die (alten) API-Verbindungen von 3 Investox-Instanzen bestehen in der TWS , obwohl diese Instanzen auf dem Test-PC längst geschlossen sind.



Zuvor scheiterten aus diesen 3 Instanzen heraus mehrere Neuverbindungs-Versuche zu IB und in allen Instanzen traten die COM-Fehlermeldungen auf-
IB-Verbindungs-Ampel stand vor+ während der Neuverbindungs-Versuche in allen 3 Instanzen permanent auf rot.

Abhilfe schafft jetzt nur noch der Neustart der TWS.
Viele Grüße von Anke

http://www.ascunia.de

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 657

Wohnort: Neuenhagen b. Berlin

22

Mittwoch, 10. April 2019, 22:30

... nach dem Neustart der TWS und von RTT für IB:

1. Investox-Instanz mit Client ID 50209015 >>> Verbindung zu IB kann ohne Probleme hergestellt werden
2. Investox-Instanz : Fehlermeldung zu bereits bestehender Verbindung zu IB erscheint beim Neustart der 2. Investox-Instanz, obwohl der Client der 2. Instanz nicht verbunden ist:




3. Nach dem Schließen der angeblich bestehenden Verbindung über den "Ja"-Button der Investox-Fehlermeldung kann aus allen Instanzen geraus die Verbindung zu IB wieder ohne Probleme hergestellt werden.
In der 3. und 4. Instanz erschienen zuvor keine Fehlermeldungen mehr zu bestehenden alten Verbindungen.

Viele Grüße von Anke

http://www.ascunia.de

Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 935

Wohnort: Iringsweg

23

Donnerstag, 11. April 2019, 12:30

Hallo zusammen

Als Zwischenbericht:

ich habe einige Logs direkt mit Herrn Knöpfel geteilt, denn alle Details kann man ja nun nicht im Internet veröffentlichen ... und gehe davon aus, dass er diese Sache wirklich mit Priorität behandelt.

Ich bin ebenfalls sehr gespannt, welche Lösung es geben wird.

@AldiM, auch wenn ich verschiedene andere Software probiere, um einen Vergleich zu haben - ich habe keine andere Software gefunden mit solch genauen Backtests wie Investox & der Möglichkeit, die Systeme anschliessend fast 1:1 im Markt umzusetzen. D.h. nein, ich möchte hier namentlich nicht auf eine andere Software zeigen, dies wird das Investox Forum bleiben.

Das aktuelle Problem wird sicher durch den Hersteller für uns gelöst werden können, dann ist das Investox ORM auch für mich wieder die Nummer 1 im vollautomatischen Handel :thumbup:
Gruss
Bernd

Registrierungsdatum: 23. Oktober 2006

Beiträge: 197

24

Donnerstag, 11. April 2019, 15:19

Hallo Bernd

hier noch meinen Einstellungen:

Investox: 7.5.5
RTT: 3.4.1
TWS: 974.4c
Java: 1.8.0_152
OS: Windows 10 alle Updates sind installiert
API: 9.72.18.0

Bei mir gibt es mit dem Datentransfer zwischen 8 und 22 Uhr keine Probleme. Meine kleinen Handelssysteme laufen in einer Investox-Instanz stabil und ordern von dort aus direkt. Ich starte den Rechner jedoch morgens um 7:45 Uhr und schalte ihn abends gegen 23 Uhr wieder aus. Ursprünglich, d.h. vor ca. drei Jahren, wollte ich ihn durchlaufen lassen. Das hat jedoch nie funktioniert, da die Datenverbindung gegen 6:30 Uhr immer unterbrochen wurde und vom System nicht wieder stabil aufgebaut werden konnte (hört sich nach deinem Problem an).

Ich drücke dir die Daumen.
Gruß
Augustus

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »augustus« (11. April 2019, 15:40)


Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 935

Wohnort: Iringsweg

25

Freitag, 12. April 2019, 12:56

Hallo Augustus

Also, Deine Geduld ist bewunderswert
Handelssysteme laufen in einer Investox-Instanz stabil und ordern von dort aus direkt. Ich starte den Rechner jedoch morgens um 7:45 Uhr und schalte ihn abends gegen 23 Uhr wieder aus. Ursprünglich, d.h. vor ca. drei Jahren, wollte ich ihn durchlaufen lassen. Das hat jedoch nie funktioniert,

Bei mir gings ja, all die Zeit. Noch irgendwie. Dann jedoch:

ich bin ja hier im Thread schon nach 1/2 Jahr Amok gelaufen <Ironie Ende> und habe nach einer Verbesserung gefragt bzw. ob ich der Einige bin mit dem Problem. Um die Kraft des Forums zu nutzen, die Beobachtungen von allen Kollegen hier,

nach einem 1/2 Jahr erst, also für mich bedeutet das gegenüber meinem jüngeren Ich, dass ich schon langsam altersmilde, wenn nicht nahezu senil geworden bin. Früher hätte ich nach 14 Tagen Zeter und Mordio geschrien, langjährige Forums-Mitglieder mögen sich erinnern an meine Power in meinen Investox-Anfangsjahren

Und tatsächlich, wenn einmal einer ernsthaft nachfragt, und dabei die Kollegen mobilisiert: es zeigt sich, dass andere mit genau den selben Problem zu kämpfen haben.

Also, der einzige Vorwurf, den ich mir heute mache, ist, dass ich dieses Fass nicht schon vor langer Zeit aufgemacht habe. Schon Ende 2018, als es wirklich ungemütlich wurde

Wie auch immer, Herr Knöpfel hat meine Logs.

UND: er hat diese Infos von Euch allen hier aus dem Thread !!!

Diese waren m.E. entscheidend, damit er "die kritische Masse an Informationen bekommen hat", die für eine Lösung nötig sind.

Noch weiss ich auch nicht, wie die künftige Lösung ausschauen wird; jedoch laufen Tests, und ich bin sehr guter Dinge, dass *unsere* beste vollautomatische Handels-Plattform, Investox, genau wieder das werden wird was es immer war, unser Stern am Himmel der Handelsplattformen!

Augustus, wenn es so wird, wie ich es mir erhoffe, kannst Du dann auch einen neuen Versuch starten, Deine Maschinen einfach 7x24h durchlaufen zu lassen; speziell wer Maschinen im RZ hat, da macht alles andere ja auch keinen Sinn ausser dem bemühten Versuch, die Gletscher nicht so schnell schmelzen zu lassen, und das ist fraglich ob es dann speziell an Deiner Maschine lag, dass die Menscheit das nächste Jahrtausend erleben wird. (Immerhin, ich bin sicher, man würde sich erinnern, und der Dank der nächsten Generationen würde so einem Individuum ewig nachschleichen, eine Greta Tunberg wird sicher auf jeden Danke zu Dir sagen, Du hast bisher 5x8h pro Woche mindestens - hoffentlich - Ökostrom eingespart :thumbsup: )
Gruss
Bernd

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Bernd« (12. April 2019, 13:17)


Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 657

Wohnort: Neuenhagen b. Berlin

26

Dienstag, 30. April 2019, 14:10

Hallo,

Zitat

jedoch laufen Tests


Wie ist denn der aktuelle Stand?
Gibt es schon Neuigkeiten?
Viele Grüße von Anke

http://www.ascunia.de

Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 935

Wohnort: Iringsweg

27

Dienstag, 30. April 2019, 21:22

Hallo Anke

Seit vor Ostern habe ich hier eine INV Test-Version am Start auf mehreren Rechnern; die Instanzen laufen ohne Probleme, Tag und Nacht. Überleben auch den TWS Wochenend Shutdown / Neuanmelden ohne Klagen (*), melden sich einfach wieder selbständig an (haben sogar Ostern überlebt ohne Neustart !!! und haben einige Tage weiter funktioniert, bevor ich aus völlig anderen Gründen einen Reboot der betreffenden Maschinen "machen wollen-musste")

Zuerst hatte ich die Test-Version auf dem Paper laufen, aber sehr bald habe ich es auch riskiert, diese Beta auf meinen echten Konten laufen zu lassen.

Den Erfolg habe ich natürlich ständig an Herrn Knöpfel berichtet, und ich kann sagen: es wird eine RICHTIG GUTE VERBESSERUNG im ORM Connectivity Bereich zu IB hin geben!

Den Zeitplan, wann Herr Knöpfel was veröffentlicht, kenne ich natürlich nicht, aber nach meinen Tests wird das Problem, warum es diesen Thread hier gibt, in Kürze und mit der nächsten Investox Version Geschichte sein !!!



PS *: also wohlgemerkt, es klappt bei mir sogar mit der TWS auf mehreren Maschinen (diese auf Autologon eingestellt um 23:55 bis 23:57 CET herum - do not use the same Restart-Time auf einer Maschine für mehrere TWSe, das klappt ned, wegen einem Problem im Datenmodell auf seiten IB. 2 Minuten Versatz pro TWS pro Maschine klappt aber bei mir), statt's dem IB Gateway - und das macht die Dinge für uns um sovieles einfacher, können wir so die Orders und Traders auch gleich Life sehen und monitoren, so gut! :) :) :)
Gruss
Bernd

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Bernd« (30. April 2019, 21:47)


Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 657

Wohnort: Neuenhagen b. Berlin

28

Dienstag, 30. April 2019, 23:54

Hallo Bernd,

hab vielen Dank für Deine Informationen, die sehr vielversprechend klingen.
Ich hoffe, dass Herr Knöpfel all seinen Ordermodul-Kunden bald wieder mit der neuen Version die gewohnte Stabilität zur Verfügung stellen möchte.

Für einige Lynx-Kunden ist mein Notbehelf (Offline-TWS 972.1r von der IB-Webseite nutzen) inzwischen eng.
Lynx stellt aktuell seinen Kunden die V 976.2c zur Verfügung, mit der leider die von Dir und den anderen Anwendern beschriebenen Verbindungsprobleme auftreten.
Der Aufforderung von Lynx zum TWS-Update kann ein Ordermodul-Anwender mit regelmäßigen Marktdaten-Abbrüchen derzeit kaum etwas entgegensetzen.
Viele Grüße von Anke

http://www.ascunia.de

Karlson

Besucher

Registrierungsdatum: 6. April 2010

Beiträge: 5

29

Donnerstag, 2. Mai 2019, 13:00

Hallo,
Es gibt ein Update für Investox 7.6.0 und RTT 3.5.0
Achtung: neue API 9.7.5 für IB installieren!

Gruß
Karlson

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 657

Wohnort: Neuenhagen b. Berlin

30

Donnerstag, 2. Mai 2019, 14:29

@ Karlson

Vielen Dank für die Info.

Die Installation der Updates innerhalb der Testumgebung lief hier reibungslos, alle Verbindungen stehen und die ersten Order sind auch ausgeführt.
Ich bin sehr zuversichtlich für die weiteren Tests.
Viele Grüße von Anke

http://www.ascunia.de

Vuego

Meister

Registrierungsdatum: 30. August 2002

Beiträge: 987

31

Freitag, 3. Mai 2019, 15:54

Reicht TWS 972.1s (stable) oder muß es 'latest' sein?

Karlson

Besucher

Registrierungsdatum: 6. April 2010

Beiträge: 5

32

Samstag, 4. Mai 2019, 08:17

Hallo,
ich habe die TWS Latest (aktuel:976.2d) installiert. Nachteil/Vorteil: Aktualisiert sich bei jeder Anmeldung auf die neueste Version.
Noch nie Probleme damit gehabt.
Gruß
Karlson

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 657

Wohnort: Neuenhagen b. Berlin

33

Samstag, 4. Mai 2019, 10:04

Hallo,
sowohl IB als auch Lynx stellen die V 976 auch als Offline-Version zur Verfügung, die sich nicht automatisch aktualisiert. Damit gibt es auch keine Probleme.
Viele Grüße von Anke

http://www.ascunia.de

Vuego

Meister

Registrierungsdatum: 30. August 2002

Beiträge: 987

34

Samstag, 4. Mai 2019, 10:36

Hallo,
Onlineversionen sind für Produktionsysteme ohnehin ungeeignet.
Mir ging es um die Info bzgl. der 976. Vielen Dank dafür.

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 657

Wohnort: Neuenhagen b. Berlin

35

Samstag, 4. Mai 2019, 13:28

Hallo,

es gibt ein ziemiches Namens-Durcheinander.
"Webbasiert" ist nicht gleich "Online".
Seit ca. 6 Wochen heißen die TWS-Versionen ohne automatische Aktualisierung bei IB + Lynx "Offline-Version".
Bei den TWS-Versionen mit automatischer Aktualisierung fehlt der Zusatz "Offline".

Viele Grüße von Anke

http://www.ascunia.de

Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 935

Wohnort: Iringsweg

36

Sonntag, 5. Mai 2019, 15:38

Gruss
Bernd

Bernd

Erleuchteter

Registrierungsdatum: 5. Juni 2005

Beiträge: 3 935

Wohnort: Iringsweg

37

Mittwoch, 8. Mai 2019, 19:08

Hallo zusammen

Nachdem ja einige Kollegen hier am Thema interessiert waren, das gleiche Problem reportet haben - und der Fix jetzt schon ein par Tage verfügbar ist:
darf ich fragen, wie es bisher bei Euch läuft, Problem gelöst mit dem neuen INV 7.6.0, hat es überhaupt jemand getestet? Oder sich in Produktion getraut?

Wenn jemand weiter Probleme hat, sollten wir jetzt dran bleiben, "wo" der Fix aktuell ist!

Wenn keine Probleme berichtet werden, zeigt es uns allen, dass wir wieder ein stabiles Investox haben.

Geschriebene Nachrichten wie "alles prima jetzt" würden aber auch Herrn Knöpfel ein gutes Feedback geben für seine stetige Arbeit am Programm.

Also, nicht schüchtern sein, haut rein in die Tasten :thumbsup:
Gruss
Bernd

hendrix1

Fortgeschrittener

Registrierungsdatum: 31. Mai 2009

Beiträge: 135

Wohnort: Köln

38

Sonntag, 12. Mai 2019, 00:53

Hallo zusammen,

ich handel zwar nicht über Interactive Brokers sondern über MT4 Fx - bin daher nicht aktuell betroffen - freue mich aber trotzdem täglich über die gepflegte und stabile Plattform Investox, und über ein lebendiges Forum.

Weiter so Herr Knöpfel, und danke an alle „PowerUser“ von deren Beträgen ich auch profitiere !



Beste Grüße
Hendrix

Philipp Männlich

Benutzer

Registrierungsdatum: 9. Mai 2016

Beiträge: 41

39

Montag, 13. Mai 2019, 08:45

Hallo,

dem Post von hendrix1 kann und möchte ich mich vollumfänglich anschließen. Auch ich finde es spitze, wie schnell hier ein offensichtlich größeres Problem dank dem Engagement von unseren "PowerUsern" einerseits und Herrn Knöpfel andererseits gelöst werden konnte.
Das gibt einem selber auch ein gutes Gefühl, selbst, wenn man von dem entsprechendem Problem nicht unmittelbar betroffen war/ist und zeigt einem, dass man mit Investox definitiv auf das richtige Pferd gesetzt hat.

Von daher: :thumbup:

LG
Philipp