Sonntag, 18. November 2018, 20:03 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: INVESTOX-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Giuseppe Männlich

Meister

Registrierungsdatum: 31. März 2004

Beiträge: 514

Wohnort: Wien

1

Mittwoch, 3. Oktober 2018, 19:44

Ein VBS-Indi mit dem Zugriff auf die Tradeliste verwendet in einem weiteren Indi liefert keine Ergebnisse

Hallo zusammen,
wenn ich den Beispielcode für den Zugriff auf Tradeliste (Investox Hilfe: Zugriff auf die Tradeliste (VBScript)) in einem VBS-Indikator "verpacke" und diesen dann im Chart mit "Formel Einfügen" hinzufüge (natürlich mit #_TradelisteEinbinden# wie im der Investox-Hilfe beschrieben) bekomme ich die Daten korrekt angezeigt.

Quellcode

1
2
3
#_TradelisteEinbinden#
#_LoadDefs#
TradeInfoField_INV_HILFE(stückzahl)


Wenn ich jetzt den gleichen Code in einem Indikator verpacke (also ein Indikator benutzt ein VBS-Indikator) und diesen im Chart hinzufüge, bekomme ich keine Daten angezeigt.

Was mache ich falsch? ?(

LG Giuseppe
keep going on...
Inv[7.5.1]

Wiwu Weiblich

Meister

Registrierungsdatum: 4. September 2002

Beiträge: 1 641

Wohnort: Neuenhagen b. Berlin

2

Donnerstag, 11. Oktober 2018, 12:56

Hallo Giuseppe,

hast Du schon mal versucht, das Schlüsselwort #_TradelisteEinbinden# als freien Text-Parameter im Indikator zu definieren?








PS: Irgendwann vor langer Zeit war es mal so, dass zusätzlich zu dem freien Text-Parameter mit dem Schlüsselwort #_TradelisteEinbinden# mindestens noch ein weiterer Parameter im Indikator definiert sein musste (ggf. Dummy).
Ob diese Einschränkung auch aktuell noch gilt, habe ich nicht getestet.
Viele Grüße von Anke

http://www.ascunia.de

Giuseppe Männlich

Meister

Registrierungsdatum: 31. März 2004

Beiträge: 514

Wohnort: Wien

3

Freitag, 12. Oktober 2018, 22:37

Hallo Anke,

perfekt, genau das hat mein Problem gelöst.

Danke!
LG
Giuseppe
keep going on...
Inv[7.5.1]

Giuseppe Männlich

Meister

Registrierungsdatum: 31. März 2004

Beiträge: 514

Wohnort: Wien

4

Sonntag, 14. Oktober 2018, 11:52

Übrigens, ich kann bestätigen, dass ein Dummy-Parameter nach wie vor notwendig ist.
LG

Giuseppe
keep going on...
Inv[7.5.1]